Weighted queries - can MEGAN take it into account?

Dear community,

In previous versions of MEGAN, there was an option to account for “weighted” fasta format. In this format, reads are assigned a “weight” in the following format:


where xxx provides the number of occurrences of the sequence in the dataset.

With MEGAN5, under “Edit > Preferences” there was a box that could be clicked on or off termed “Use Magnitudes”. I believe this was telling MEGAN to account for the number that appears after the _weight| sting in the sequence ID. Since i cannot find this box in MEGAN6 I wonder - is this feature still available? if yes - how can it be switched on?


Yes, use the one of the following to define a “magnitude” of 666 for a fasta record:

weight|666 or weight=666 or magnitude|666 or magnitude=666

Then, set the “read assignment mode” to “readMagnitude”.
This can be done using the LCA parameters tab of the Import Blast tab in MEGAN or
using the command line option “–readAssignmentMode” when using e.g. daa-meganizer

Daniel hi.
Thats great! I will try that. I will get a bit greedy here and ask whether this can be done AFTER importing a tabular file from blast? (but I guess this is not possible)

in any case - thanks!

Dear Daniel and MEGAN community members,
Trying to upload my rma6 files on a new computer I encountered a problem:

I generated my .rma6 files on the computer cluster of my faculty using weighted queries (in the following format: QUERY_ID_weight|xxx). To do so i switched on the “readMagnitude” switch under the LCA parameters tab which worked just fine. However, when i tried opening the same files on my personal laptop the program ignored the weights and simply counted the number of reads (which means that i get wrong numbers of reads assigned to the relevant KEGG entries / taxa). I then tried to change that by opening the files and switching on the switch under Options > Change LCA parameters > read assignment mode (and change to readMagnitude) but that didnt seem to solve the problem. Can anyone tell me what it is that i am doing wrong?

Dear Dan,

are you using the same MEGAN version? The way that magnitudes are handled has changed over time, so a difference in version may be the explanation.
Otherwise, it is possible that there might be a file encoding issue. I assume that at the server is Linux and the laptop is either Windows or Mac (which one)? Could you give me access to a file that exhibits the problem?

Hi Daniel, Thanks for your reply.
I think that the files were indeed generated using an older MEGAN6 version than the one i used to open them on my laptop, but the second comment is also true - the cluster is running under a linux OS while the personal computer uses Windows.
I will try to send you an example for a problematic RMA6 file in the next few days.
All the best.

Dear Daniel,
Here is a link to one of the rma files i mentioned (I selected a relatively small file)


Do you think this problem is solvable?

Best regards,

Dear Daniel, here is a short update:
I was trying to upload one of the rma6 files (the one i uploaded to the google drive) on a MEGAN6 instance on a linux operated system (openSUSE Leap, v42.3) to check whether this is a linux / windows “incompatibility issue” as you suggested. unfortunately i observed the same problem again: The magnitudes that were considered on the first platform i was working with (Ubuntu 14.04.4) were not accounted for on the new system :(.
Hope to hear more from you soon!
Thank you,