Unable to open MEGAN

Dear MEGAN Community,

I am unable to open the MEGAN 5 software. Here are the details

  1. I was able to open MEGAN5 just fine in the past

  2. I updated my MEGAN to MEGAN6 and it worked fine.

  3. I am trying to reinstall my MEGAN5 in a different directory. The idea is to have both MEGAN5 and MEGAN6 available because my supervisor sometimes prefer the color scheme from MEGAN5 which as far as I understand is not available in MEGAN6.

  4. after installation of MEGAN5 in different directory, I can’t open the MEGAN5, whenever I click and try to open the software there will only be a loading icon (the blue circle icon) for a few seconds then it disappeared and nothing happens.

  5. an error file is generated saying:
    MEGAN fatal error:
    java.lang.NumberFormatException: For input string: “32644;37965;134367;2323;28384;61964;48510;47936;186616;12908;48479;156614;367897;”
    For input string: “32644;37965;134367;2323;28384;61964;48510;47936;186616;12908;48479;156614;367897;”

  6. My MEGAN6 which is in different directory though, is still working well.

I look forward to receiving your answer


MEGAN5 and MEGAN6 share the same properties file, and it looks like there might be an inconsistency in how something is stored in the properties file.
You can specify a different properties file for MEGAN5 by passing
-P properties-file
on the command line when starting MEGAN5, where “properties-file” is the name of some empty file that you have created.

However, such a problem shouldn’t prevent the program from starting, so please send me the full error.log file so that I can try to figure out what the problem is

Dear Daniel,

Thank you for your reply

I am running MEGAN in Windows10.

Instead of command line, I usually open MEGAN by just double clicking the Megan.exe. I am wondering how can I specify different properties file for MEGAN5.

In the error.logs file, there is only the texts I wrote above, there is nothing else.
MEGAN fatal error:
java.lang.NumberFormatException: For input string: “32644;37965;134367;2323;28384;61964;48510;47936;186616;12908;48479;156614;367897;”
For input string: “32644;37965;134367;2323;28384;61964;48510;47936;186616;12908;48479;156614;367897;”

Edit: Is the error log file you were asking is in the c:/Program Files/Megan folder (Where I installed the Megan5)? Let me know if what you mean is a different file that is in a different directory.

Irvanerror.log (258 Bytes)

I installed both MEGAN5 and MEGAN6 on a windows machine and didn’t experience your problem. Try locating and deleting the properties file .Megan.def.
Sorry that I can’t help you further, we no longer provide support for MEGAN5.

Dear Daniel,

Thank you somuch

I finally found the file and deleted the .Megan.def. and it worked.