Unable to extract reads

until recently, I never got problems with the extraction of reads from selected nodes. But now I regularly get the following error message:

Version MEGAN Community Edition (version 6.14.2, built 23 Jan 2019)
Copyright © 2019 Daniel H. Huson. This program comes with ABSOLUTELY NO WARRANTY.
This is free software, licensed under the terms of the GNU General Public License, Version 3.

Opening startup files
Loading ncbi.map: 2,031,704
Loading ncbi.tre: 2,031,708
Induced tree has 2,031,708 of 2,031,708 nodes
Executing: open file=‘C:\Users\R_Rosenstein\Desktop\NG-15006_NS2_lib239539_5807_1_1plus2.rma6’;
Info: Opened file ‘C:\Users\R_Rosenstein\Desktop\NG-15006_NS2_lib239539_5807_1_1plus2.rma6’ with 21,610,091 reads
Info: Command completed (15s): open file=‘C:\Users\R_Rosenstein\Desktop\NG-15006_NS2_lib239539_5807_1_1plus2.rma6’;
Induced tree has 497 of 2,031,708 nodes
Induced tree has 497 of 2,031,708 nodes
Executing: collapse rank=‘Species’;select rank=‘Species’;
Induced tree has 497 of 2,031,708 nodes
Induced tree has 497 of 2,031,708 nodes
Executing: show window=ExtractReads;
Executing: extract what=reads outdir=‘C:\Users\R_Rosenstein\Desktop’ outfile=‘C_propinquum.fasta’ data=Taxonomy ids= 43769 allBelow=false;
C_propinquum.fasta (Zugriff verweigert)
Command usage: extract what=reads outDir= outFile= [data={EGGNOG|INTERPRO2GO|KEGG|SEED|Taxonomy}][ids=<SELECTED|numbers…>]
[names=<names…>] [allBelow={false|true}]; - Extract reads for the selected nodes
C_propinquum.fasta (Zugriff verweigert)
Error: Execute failed: java.io.IOException: C_propinquum.fasta (Zugriff verweigert)

It seems that the access is denied to a file that has to be generated.

Any ideas what could be wrong with my MEGAN installation?

Thank you,


I just tried this on a Windows 10 installation, I was able to extract reads to a file on my Desktop… I am not sure what the cause of the problem is that you are having…

Hi Daniel,
I get this error with both of my MEGAN v. 6.14 installations (Windows 7 and Windows 10). With a older MEGAN version (6.8) on a Linux installation it worked fine.

I just installed MEGAN6 6.15.0 and the extraction of reads works fine on all my platforms :slight_smile: