Trouble importing some blast outputs into megan6

Sorry for starting two threads in one day, but I have another problem importing blast outputs into megan6. Some wont open at all. Here’s an example from the smallest output file I could find that I couldn’t open: Status bar keeps saying ‘Analyzing reads % alignments: Processing alignments Busy’ and the message board says:

Executing: show window=ImportBlast;
Executing: import blastFile=’/Users/xxx/Downloads/16s_96-90.txt.blast.output.txt’ meganFile=’/Users/xxx/Downloads/16s_96-90.txt.blast.output.rma6’ useCompression=true format=BlastText mode=BlastN maxMatches=100 minScore=50.0 maxExpected=0.01 minPercentIdentity=0.0 topPercent=10.0 minSupportPercent=0.01 minSupport=1 weightedLCA=false weightedLCAPercent=80.0 minComplexity=0.0 useIdentityFilter=false fNames= paired=false;
Executing: ‘import’‘blastFile’’=’’/Users/xxx/Downloads/16s_96-90.txt.blast.output.txt’‘meganFile’’=’’/Users/xxx/Downloads/16s_96-90.txt.blast.output.rma6’‘useCompression’’=’‘true’‘format’’=’‘BlastText’‘mode’’=’‘BlastN’‘maxMatches’’=’‘100’‘minScore’’=’‘50.0’‘maxExpected’’=’‘0.01’‘minPercentIdentity’’=’‘0.0’‘topPercent’’=’‘10.0’‘minSupportPercent’’=’‘0.01’‘minSupport’’=’‘1’‘weightedLCA’’=’‘false’‘weightedLCAPercent’’=’‘80.0’‘minComplexity’’=’‘0.0’‘useIdentityFilter’’=’‘false’‘fNames’’=’‘paired’’=’‘false’;
Classifications: Taxonomy
Parsing file: /Users/xxx/Downloads/16s_96-90.txt.blast.output.txt
Error parsing file near line: 24147: Can’t parse match with Strand = Minus / Minus
Total reads: 17
Alignments: 621

I have a few other files that I can’t open where I get the same message. What can I do to get them to open?
Thank you in advance!

What alignment tool did you use? I have never come across alignments with Strand = Minus / Minus…

Could you please give me access to one of the blast files and I will look into this…

Hi again, Thank you so much for the help! Here’s a link to a small blast file that wouldn’t open:

Hello there,
This is my first mail to MEGAN6 community. I face the same problem! so I will be pending to your post.

Hi Gustavo! Welcome to the thread - let’s hope we solve it :slight_smile:

I found the problem, fixed it and will upload a new release later today

Cool!! Thank you so much!!!

Please update to V6.4.7

I just installed the update - sadly, both issues still occur. That is, I cannot open the blast output file I shared with you in this thread, and the OTUs are still mixed up when I open the file that I shared with you in the other thread.

However, I tried both updating through Help-Check for updates and downloading 6.4.7 through the website. Using both these ways to to get 6.4.7 after I’m done installing the V6.4.7 the top bar still says Megan Community Edition (version 6.4.0, built 11 May 2016). Could that be the issue?

Dear Kristine,

thanks for your message. There indeed seems to be a problem with the installer builder… The version currently shipped in MEGAN appears to be 6.4.0, which is incorrect, I will fix as soon as possible

Dear Kristine,

thanks for your input… I figured out that MEGAN was using stale library file that masked updates to the program (hence wrong version in window bar and “missing” new features). Should be fixed now…

Dear Daniel,
Everything is working - the update, the import of blast outputs and the taxa assignments do not get mixed up between the sequences!! Thank you so SO much!!! Have a great weekend & thanks again!