Set properties file path for sam2rma and rma2info CLI tools

I have a question regarding the configuration of MEGAN sam2rma and rma2info tools.
As far as I understood by using them, these tools will look for the properties file (".Megan.def") file in the home directory. Is it be possible to specify a path to a properties file when calling sam2rma and rma2info and override this behavior?

Thank you very much in advance,

Sounds reasonable, but unfortunately, at present, the is now way to specify the properties file for the tools programs. I will add this (in about two weeks)

Hi Daniel,

Thank you very much for your quick response! And also thanks for maintaining and developing the whole MEGAN suite, such a great set of tools!

Have a nice day

I have just uploaded a new release that has a -P option

Hi Daniel,

This is great! Thank you so much!

Hi Daniel, I seem to encounter a problem with the way the -P behaves with sam2rma.

Just a little bit of context: I set up an additional classification (*map and *tre) files and want to use those instead of the ncbi ones.

This is what my MyProperties.def file looks like (newick file with taxon ids, and map file with 4 columns):

The MEGAN GUI loads these without a hitch (when calling MEGAN -p MyProperties.def) and displays my custom taxonomy. I also get the message before startup:
Loading additional classification CLASSIFICATION from: /path/to/my/CLASSIFICATION.tre and /path/to/my/

Conversely, sam2rma, regardless of the properties file specified via -P loads the ncbi.tre and default files.

Thank you very much in advance!


Quick addendum: I found a quick (albeit unelegant) fix. I modified the megan.jar file in a copy of MEGAN 6.24.1, and overwrote the ncbi.tre and files by my custom files. Taxonomy assignment works in this case.

I will try to figure out what is going on.