SAM import to Megan

I use MALT to produce one RMA6 and one SAM file in parallel (i.e. in the same run), the contents should be exactly the same. The RMA6 file works fine in Megan but the SAM file get only two nodes in the tree: “NCBI” in one end and “Not assigned” in the other. This is the same for all files that I tried so far; the RMA6 file gives nice trees with a numerous nodes and leaves, while the SAM always only gives two nodes… How could it be that the difference is so large???

The SAM file is imported by “Import from BLAST”-> “1. Specify the BLAST…”, no error-message is showed and all sequences are imported, here is the outprint:

Parsing file: E:\BleFilerMalt\007_18.sam
Total reads: 503,636
Alignments: 2,369,535
Initializing binning…
Using ‘Naive LCA’ algorithm for binning: Taxonomy
Binning reads…
Total reads: 503,636
With hits: 503,636
Alignments: 2,369,535
Assig. Taxonomy: 0
MinSupport set to: 251
Min-supp. changes: 0
Numb. Tax. classes: 1
Class. Taxonomy: 1
Info: Command completed (253s): ‘import’‘blastFile’’=’‘E:\BleFilerMalt\007_18.sam’‘meganFile’’=’‘E:\BleFilerMalt\007_18-2.rma6’‘useCompression’’=’‘true’'for…
Induced tree has 2 of 2,175,510 nodes
Induced tree has 2 of 2,175,510 nodes

The two nodes are two nodes; “NCBI” in one end and “Not assigned” in the other
How is it possible? NB; exact the same 503,636 reads in the RMA6 file produces a nice tree!

And, if possible even more strange (?): I produce a SAM file in BLAST and try to import it the same way, with the same result, just two nodes; “NCBI” in one end and “Not assigned” in the other… This while a txt file from BLAST of the same result produces an impressing tree!

I spent some hours on this problem, but I can’t find the easy answer that most probably is somewhere out there.

Greetings from Sweden!


Dear Per,

did you a mapping file, in the case of DNA against DNA alignments, you should use this file (unzip before use):

Super - it worked fine!