Running MEGAN6 install with JDK12 - "Installer file seems to be corrupted"

Hi there!

I (finally) got the right Oracle JDK in my path, and that seems to be okay, but now I keep getting the following error:

kate@~$ ./

gzip: sfx_archive.tar.gz: not in gzip format
I am sorry, but the installer file seems to be corrupted.
If you downloaded that file please try it again. If you
transfer that file with ftp please make sure that you are
using binary mode.

I have tried redownloading the file many times. I do have to move it onto a remote server - could that be corrupting it? I have tried scp-ing like normal, turning it into a .tar.gz before scp-ing, as well as directly downloading it to the server via wget. I’m using jdk 12.0.2. Any help would be really appreciated. The server is a x64 Ubuntu. I’m kind of at a loss. Thanks!

I just downloaded the file from the website and installed the program on linux without any problems.
To try and help you, I have put a zipped file onto the website, perhaps downloading and then unpacking this will fix the problem (however, unfortunately, I have no idea what the problem is):