Problems with ("File has wrong magic number")

I recently did a new install of Megan6 (v.6.4.15) and downloaded the current mapping file for protein-entries ( I unzipped the mapping file and started MEGAN6.

However when I try to load the mapping file within megan6 (either for importing from BLAST or for meganizing daa-files) nothing happens. I do not get an error message, but the mapping file does not seem to be loaded, regardless.

Normally when megan6 imports such a mapping file the “Use Accession” box should become ticked, which is not the case here. Also, ALL of my reads end up as “unassigned”.

I then tried to use the command-line based “Blast2LCA” tool instead. This tool gave me an Java-exception, stating that the mapping file has a wrong “magic number”: File has wrong magic number
(Probably it was meant that this message should also appear in the GUI version of megan6?)

So I’m guessing the mapping files I downloaded are broken? However, I tried downloading several times, always with the same result.

Could you provide md5checksums for these mapping files, to double check if the problem is on my side?

Ok, nevermind, I did not have the newest version of megan6 after all. Was sure I had done a fresh install of the newest version, but the installation was not completed due to permission-issues. With the actual current version everything works fine.