Problem with blast outputs

I have blastn output from just 9 OTUs/sequences, named OTU1, OTU2 etc. Using ‘import from blast’, I imported this blast output to megan6. Before uncollapsing, I used ‘inspect’ to see the assignments for the 9 OTUs - that looks good. But, when I ‘uncollapse’, the OTUs are not assigned to the right taxa, e.g. a giraffe sequence is suddenly clustered with homo sapiens sequences and thereby assigned as homo sapiens. When I change the LCA parameters, I can get the 9 OTUs to ‘un-cluster’ more from each other, but then the sequences are mixed up so that e.g. what is really a solenodon sequence is assigned to be a giraffe. So the taxa are right, but they are assigned to the wrong OTUs. When I ‘inspect’ the assignment for the erroneous giraffe assignment, it says: ‘Taxonomy - giraffa camelopardalis (1), then OTU1 (100), data, solenodon paradoxus; score =196.0’ etc etc. So the underlying data (blast output) are good enough and still kept in megan, but the taxa assignments and OTUs seem to mix up the second I uncollapse. Importing blast outputs like this usually works flawlessly, but now it seems there’s a mix up the sequences and the names/assignments. So my question is - is there some setting that I’ve changed without noticing that causes this / how do I get megan to assign the OTUs to the correct taxa? Thanks in advance!

Could you please do the following: open one of the reads that is wrongly assigned in the inspector window and then copy all the alignments associated with it and send them to me and I will look at this.
(Also: Are you using the mapping file gi2tax-Nov2015.bin? That particular version had a number of errors in it).

Thank you for your quick reply! I have attached a shot of the one of the wrong assignments.

I dont know where I see which mapping file I’m using?

could you open up the alignments so I can see what is being used to get these taxa…

I can’t open the alignment for it - sorry:

ok, please give me access to one of your blast files

I hope you can open this: