Problem importing 3-string CSV files into MEGAN6


I am a new user of MEGAN6 (v6.6.7) on Windows 10, and I have been very impressed by its functionality!

I am currently trying to export the results of a BLAST search from Geneious into MEGAN6, as a .csv file, but I am having difficulty importing .csv files into MEGAN6. Specifically, I am able to import 2-string format files, (that include taxon and count information), but I cannot import 3-string format .csv files, that includes contig, taxon and bitscore data.

I have pasted below part of my input file, (a .csv file formatted in Notepad):

Contig 281,“Acacia merrallii”,425.85
Contig 281,“Acacia merrallii”,425.85
Contig 272,“Medicago polymorpha”,462.783
Contig 281,“Falcataria moluccana”,420.31
Contig 281,“Acacia confusa”,420.31

I have also tried the same file without the “” around the taxon names, with the same result.

The error messages I get are “Error: java.lang.NullPointerException, skipping”, “Warning: Lines skipped during import: 8123 (of 8123)”, and “Info: Imported 0 reads from file”. The program then freezes and I have to restart it.

I have copied out the example given in the manual, pasted it into notepad, and tried to import it, but that didn’t work either, (I have re-pasted it below):

r01, Escherichia coli CFT073, 100
r01, Escherichia coli K-12, 110
r01, Salmonella enterica subsp. enterica serovar Choleraesuis str. SC-B67,120
r02, Caldicellulosiruptor saccharolyticus DSM 8903, 90

The error messages that appear in that case are the same (except of course for the number of lines skipped), and the program also freezes.

Any advice you might have would be greatly appreciated!

Best Regards,

Dear Tim,

thanks for the bug report. I have fixed the problem and the fix will be available in release 6.7.0 very soon

Hi Daniel,

Thanks very much! I really appreciate your help.

Best Regards,