KEGG data for daa2rma command

Hi there,

I am working on the process of converting DAA files to RMA files using daa2rma command line.

From the website of MEGAN6:

There is a mapping file from

I suppose that is for --mapDB parameter?

Does it mean there is no need to give input for the parameters such as --acc2taxa, --acc2eggnog and --acc2interpro2go?

In addition, I understand that doesn’t contain information about KEGG pathways. But If I have data from KEGG website ( and is there any way that I can provide daa2rma with the KEGG data? If so, how?

Many thanks,

yes, use the file with the --mapDB parameter.

Correct: the --acc2taxa etc options are no longer required, the db file contains all those mappings.

To use your own KEGG mapping, you need to add another column ‘KEGG’ to the mapping tables. It should provide the KO id for those accessions, for which the KO id is known.

I will update the CE map file to contain the old 2011 mappings of KEGG later this week.

Hi Daniel,

Good to know that the new mapping file will include KEGG information and look forward to it!

A further question is which file in the KEGG ftp site can be used to add to the mapping tables?

I have checked that megan-map-Oct2019.db looks like binary. Is there a way I can add the “KEGG” column to the existing mapping tables?

Many thanks,

megan-map-Oct2019.db is a SQLITE database file and you can open it using sqlite3 on linux or MacOS. You can add columns to it etc, see the SQLITE documentation for details.
To get you started:
Use the sqlite command .schema to see the database schema and
use the sqlite command select * from mappings limit 10; to list the first ten rows in the mapping table.

Unfortunately, I don’t have a 2011 mapping file for KEGG so I won’t be able to add KEGG mappings to the database… To use KEGG, you will either have to add your own KEGG mapping to the database or use MEGAN UE.

Dear Tom,

I found the same issue with you. Do you already solved your problem? I’ve extracted the database from MEGAN download file and running it with --mapDB but it doesn’t work in me. How to make it works for convert .DAA file to .RMA file with daa2rma?

I use this command line:

daa2rma --in /home/husna/lulu/alignment/HA_result.daa --out /home/husna/lulu/rma-output/HA_result.rma --mapDB megan-map-Oct2019.db

And i got this output:

Version MEGAN Community Edition (version 6.12.3, built 14 Aug 2018)
Copyright © 2018 Daniel H. Huson. This program comes with ABSOLUTELY NO WARRANTY.
jloda.util.UsageException: Invalid, unknown or duplicate option: --mapDB megan-map-Oct2019.db
, use option ‘-h’ for help
at jloda.util.ArgsOptions.done(

I already check daa2rma -h but there is no parameter --mapDB. So I try to use parameter such as g2t etc but it still doesn’t work. Do you have an advice for me to make it works?

Thank you for your help


you are using a version from 2018. You need to use the latest version.