Java Error uploading mapping files for Taxonomy


I am currently working with MEGAN analyzing some metagenomic data.

First I performed BLASTX with diamond v8 and it generated files in .daa format. For taxonomic assignment I am currently working with MEGAN, but since I downloaded the latests version 6.7.1 I am getting the following error:

line 1: input ‘Taxonomy’ does not match any of legal tokens: EGGNOG INTERPRO2GO KEGG SEED

Error: Execute failed: line 1: input ‘Taxonomy’ does not match any of legal tokens: EGGNOG INTERPRO2GO KEGG SEED.

I am using databases prot_acc2tax-Nov2016.abin and prot_gi2tax-Aug2016X.bin downloaded directly from the MEGAN website.

Not only that, but when I am trying to upload the taxonomy file into the Meganizer window, the taxonomy window dissapears every time I close it, and I need to restar MEGAN for generating again. I downloaded the latest version of Java and JRE but I don’t understand what this error means.

I would be very grateful if you can help me.

Thank You,

This bug only affects 6.7.1, please update to 6.7.2


I encountered the same problem/error while importing diamond blastx results with version 6.7.2.

Thank you for your help!

Please try 6.7.3, if that still doesn’t work, then please send me a screen shot showing exactly what you are attempting to do… Also, please let me know which OS you are using.

I tried 6.7.3 and is works now. Thank you very much!


Since I download the new version of Megan6 v6.7.3 " built 10 Mar 2017" for OSX, there is a bug concerning taxonomy tree. My Data (from a CSV file with virus taxo and counts) seems to be download but then, when I want to change the rank to create a tree, nothing happens, I can not do something except kill the app Megan6.
I have used same data file with the last version of Megan6 or Megan5 and It was okay.


Dear Amelie,

could you give me more details. I have tried opening CSV files that I have and that appears to work without a problem, perhaps give me a screen shot that shows the problem, or what do you see in the Log Window?

Hi Daniel,

Here is a screen shot.

This screen shot is after a kingdom rank request: first, the tree is not correct (my data contains only virus) and finally, the app doesn’t response anymore if I request modifications of rank (I have to kill the app). It is the same kind of bug with any ranks (family, genus, speces…)

I have tried the v6.7.4 and it still doesn’t work.

Thank you

Could you please give me access to the CSV file that you are attempting to process and I will run this through debugging.

Hi Amelie,

I took a look inside your file:


The reason why CSV import is failing is that MEGAN can’t parse taxon names that are prefixed with taxonomic rank indicators such as d__, f__ etc.
So, a quick fix is to simply replace all underscores in your file by spaces (including those inside names) and the file then can be imported.

Hi Daniel,

Thank you, I replaced all __ or _ by a space in all data (including inside names) and it still doesn’t work. (I also removed rank indicators to test and it’s the same problem.) Even if I remove “|” it is the same thing.
By the way, I tried with v5.11.3 and all files worked perfectly (with __ or without)
Do you have any suggestions or idea to fix my problem?



I have the same issue as Amelie, the file with __ and taxonomic ranks works perfectly in MEGAN5 but it doesn’t work in MEGAN6. Any updates on this issue?