IOException: TRANSLUCENT translucency is not supported

Dear MEGAN users,
I download non-redundant proteins of bacteria and archaea fron NCBI refseq database released September 16, 2019 and make a diamond dmnd file.
I blast paired-end mRNA sequences against the database and I got the daa output.

  1. When I meganized the daa file using
    bash /software/megan/tools/daa-meganizer -i qc_pear_sort.daa -g2t prot_acc2tax-Jul2019X1.abin -g2eggnog acc2eggnog-Jul2019X.abin -g2interpro2go acc2interpro-Jul2019X.abin -g2seed acc2seed-May2015XX.abin.
    Only reads were mapped to taxonomy database but no reads were mapped to eggnog, seed, interpro2go database.

  2. I updated the MEGAN version from 6.17.0 to 6.18.0 and downloaded megan-map-Oct2019.db.
    DAA file was meganized by the below command:
    bash daa-meganizer -i IS1_qc_pear_sort.daa -mdb megan-map-Oct2019.db
    It worked.
    But when I open the meganized file in MEGAN 6.18.0, megan was hanging and it shows
    IOException: TRANSLUCENT translucency is not supported.

Does anyone have any idea why it happen and how I should fix this problem?

Thank you very much.
Best regards,

Dear all,

I get the same message when I connect to Megan (on Ubuntu 18.04) via X2Go.

Today I upgraded Megan community edition from 6.15.2 to 6.18.0 (Ubuntu).

When I connect remotely via X2Go I can start Megan and I can make a new rma6 from the data, but I cannot open previously made rma6 files (also not the newly made rma6). The message is:

UnsupportedOperationException: PERPIXEL_TRANSLUCENT translucency is not supported
Command usage: open file= [readOnly={false|true}]; - Open a MEGAN file (ending on .rma, .meg or .megan)
IOException: PERPIXEL_TRANSLUCENT translucency is not supported

I googled about this issue and it is likely a Java-X2Go interaction. For the install of Megan 6.18 I also had to upgrade to Java 11, and that probably broke the system. Without X2Go all works and actually I think that it is an X2Go bug. However, we have a VM running on the server and the only way to login graphically is via X2Go.

Is it possible to run Megan without the need for PERPIXEL_TRANSLUCENT translucency, or with java 8 as it used to run? Else I may revert to the last pre-java 11 version (apparently that is 6.17)

– Edit 2 typos

Note: I reverted to version 6.15.2 and it worked

I am sorry to hear about this.
I think that this might be to do with (new code for) showing notifications. You can turn that feature off using Edit->Preferences->Show Notifications (which is a good idea when using MEGAN remotely, anyway).

I will investigate this and will modify the notifications code so that it doesn’t throw the exception.