IOException: invalid CEN header

Hi everyone,

I am trying to import three large BLAST xml files (each over 1 GB zipped, the largest is 2.8 GB) into MEGAN 6.10.2, but it fails with the error “IOException: invalid CEN header (bad signature)”. I tried unzipped files, but the error persists. The MEGAN parses my smaller files (~300 MB zipped XML) without problem. I tried increasing available memory to 7 GB, it didn’t help.

The XMLs come from a local BLAST of 16S reads against SILVA ref 99 v128.

I will appreciate any help - many thanks!

New trial: the default output option of blastn produces much smaller BLAST outputs (zipped 600 MB), but still the same error. If I try to open an early, unfinished version of the output (a few MBs) opens without problem. Is this related to related to the file size? Is there a way around it?


Seems like a file size issue indeed: if I split the fasta and do several blastns, the smaller outputs are read into MEGAN without error.

Sorry for the slow reply, I was traveling and had no time to visit the forum…
If you could give me access to the smallest big file that doesn’t work, then I’d be happy to try and fix this.