Invalid daa file

**Hi everyone, **

This is my first time in Megan,
I and running shotgun data using paired-end reads

I used this
###1.Install Megan

###2.This file in neccesary is we want meganizer

###3.Download and install DIAMOND

###4.Download the NR database from here

###5.Build a DIAMOND index
diamond makedb -d nr --in nr.gz

###6.This results in an index file

###7.Run DIAMOND (in query we use the name of our sequences) - ESTO SE DEMOR√ď CORRIENDO 15 D√ćAS
diamond blastx --db /vault2/bioinfDBs/diamondDB/nr.dmnd --out reads_shotgun.daa \ --outfmt 100 --query /vault2/homehpc/voteroj/SEQ_SHOTG/T4P4_T1_TCCGCGAA-GTACTGAC_L004_R2_001.fastq.gz

###8.This will produce a DAA file called

###9. Before run MEGANIZER, we need the following database, we can download from Megan website:
###The following file maps NCBI-nr accessions to taxonomic and functional classes (eggNOG, InterPro2GO and SEED), unzip before use:

And then when I tried to meganizer using this script:
nohup /vault2/soft/bio/megan6/tools/daa-meganizer -i reads_shotgun.daa \ -mdb megan-map-Oct2019.db -v &

The result obtained; attached at the end of the message; I do not how to figure out, Do you have any suggestion, please.

**Thanks in advance, **
Best regards,
Vanessa O.J.

Version MEGAN Community Edition (version 6.18.9, built 4 Apr 2020)
Copyright © 2020 Daniel H. Huson. This program comes with ABSOLUTELY NO WARRANTY.
GLib-GIO-Message: Using the ‚Äėmemory‚Äô GSettings backend. Your settings will not be saved or shared with other applications.
Java version: 11.0.1
Functional classifications to use: EGGNOG, INTERPRO2GO, SEED
Loading 2,175,506
Loading ncbi.tre: 2,175,510
Loading 30,875
Loading eggnog.tre: 30,986
Loading 13,501
Loading interpro2go.tre: 29,204
Loading 13,662
Loading seed.tre: 21,085
Meganizing: reads_shotgun.daa
Meganizing init
Caught: Invalid DAA file. DIAMOND run probably has not completed successfully.
at megan/
at megan/
at megan/megan.daa.DAAReferencesAnnotator.apply(
at megan/megan.daa.Meganize.apply(
at megan/
at megan/

MEGAN is reporting that the file may be incomplete… Could you please try running the diamond view command on the file to see whether diamond also reports an incomplete file.

**Hi Daniel, thank you for your answer, I run this, I don’t know if is the correct way, **

diamond view --daa/-a reads_shotgun.daa --out/-o reads_shotgun_final.daa --outfmt/-f 100 --compress 1

But, the answer was

Error: Invalid option: daa/-a

My file reads_shotgun.daa has 217.363.456 KB.
Thanks in advance.


Please update to the latest release of Megan - the problem has been fixed

1 Like