Export CSV "readName_to_taxonPath" not exporting any file

Currently using MEGAN 6.25.3 community version on Mac Monterey. Exporting CSV does not give any option for where to save the file nor does it produce any file when I click ‘OK’.

I have attached a small sample of the .rma file
ASV.fasta.nt.blastn.format5-Extracted.rma (20.0 KB)

Nevermind, the issue has resolved itself on its own.

Edit: It worked once, but has not worked again. I am wondering if this a bug to do with the latest update.

Hi @Kristen Are you able to generate an output that looks like this below? - This is my output from Diamond, but DIamond does not add family, subfamily, genus and specie into the .tsv output file. Do you know how to do this on MEGAN?

length mismatch evalue bitscore staxids sscinames sskingdoms skingdoms sphylums virus.class virus.family virus.type host stitle
62 33 4.97E-06 47.4 491893 Abalone shriveling syndrome-associated virus Viruses Heunggongvirae Uroviricota Caudoviricetes unclassified dsDNA invertebrate YP_002333623.1 helicase [Abalone shriveling syndrome-associated virus]

I just tried this: opened the file you provided:

  1. I selected the node Homo sapiens and then

  2. I selected the following menu item:

    File->Export ->Text (CSV) Format…

  3. This opened the Export to CSV dialog and

  4. I was able to select a format and save the data.

So in which step did this fail for you? Note that (2) only works if you selected some node in taxonomy or one of the functional viewers.

Thanks Daniel,

The bug seems to have resolved itself and this method seems to be working. Originally, step 3 would not happen and I would not be able to generate the file no matter if I selected 1 node or all the nodes.


Hi Kristen,

I’m encountering this bug now; I’m on MacOS Monterey and cannot export a CSV from either newly-generated .rma6 files or old ones I’ve made in the past. Did you simply reset your computer or did the program just start working again out of the blue?



I really don’t see how resetting a computer or reinstalling the software can possibly fix this. Are you sure that you have selected nodes in the viewer that is in the foreground when you select the menu item? If nothing is selected in the front viewer then the menu item won’t be enabled. Please double check that this is not the root of the problem.

Hi Daniel,

Yes, I’ve selected all the nodes. I’m then able to select the export settings I want (readName_to_taxonPathKPCOFGS), but after confirming, no file is produced. As I mentioned, I’ve tried with both a newly generated .rma6 file and ones that have produced working exports in the past.

Any other troubleshooting guidance would be appreciated.


Has anyone found a solution for this? I am seeing the same problem when I try to export readname_to_keggname. I have Megan UE

Hi, I think I am experiencing something similar. Specifically in my case, when I export readName_to_taxonPathKPCOFGS, the diaglog box pops up, allowing me to choose count and separator but the file browser for specifying file name and saving does not show up when I click “ok”. This is for version 6.25.9 (CE) on a MacBook Pro M3 Pro macOS Sonoma 14.2.1.

I tried on an different computer (macOS Catalina 10.15.7 Intel processor) with 6.20.17 (CE) installed with the same rma6 file from the newer computer and it was able to work.