Error message with .daa file


one of my .daa files constantly causes an error message when trying to meganize it or import it via “Import from Blast”. The error code is:

readNullTerminatedBytes(): failed (EOF)

BTW: this is the only file I I got from aligning via Diamond on a Linux computer. All the other .daa files that are accepted without complaints come from Windows computers.
And the erroneous file works well with command-line meganization via daa2rma.

Any chance to repair the defective file or do I have to run the Diamond alignment again?

Thank you,


can you run daa2info on the file without problems?

Hi Daniel,

yes, it seems so. At least I get similar outputs with my problem file and another file that worked fine.

Like so (problem file):

#./daa2info -i NG-11226_269_lib157502_5050_7_1.daa [ 2:17]
Version MEGAN Community Edition (version 6.7.4, built 13 Mar 2017)
Copyright © 2017 Daniel H. Huson. This program comes with ABSOLUTELY NO WARRANTY.
Loading MEGAN File: NG-11226_269_lib157502_5050_7_1.daa
Caught: DAA file has not been meganized: NG-11226_269_lib157502_5050_7_1.daa
at megan.daa.connector.DAAConnector.(
at megan.core.MeganFile.getConnector(
at megan.core.Document.getConnector(
at megan.core.Document.loadMeganFile(
at megan.core.SyncArchiveAndDataTable.syncArchive2Summary(
at megan.core.Document.loadMeganFile(

Thank you


Dear Ralf,

Probably easiest if you rerun DIAMOND.
Before that, could you please see whether you can use DIAMOND and its view command to create e.g. a tab file.
If that fails, than that would suggest that the DAA file is corrupted, if that succeeds then it could be a bug in daa-meganzier, which would like to look into, if you can give me access to the file.

Dear Daniel,

just tried DIAMOND view with my DAA file and got an Error: Error reading file…

So no need to do any debugging :wink:

Thank you,