Error in read extraction

Hi, I’m trying to extract reads from a .rma6 file in the MEGAN Community Edition (v.6.20.17). The file includes multiple blast/fastas that were inputted together from BLAST. This used to work fine on older versions of MEGAN, but for some reason, I’m running into an error now.

This is the error from the log:

Executing: extract what=reads outdir=‘F:\data\Ghost-range\sedaDNA-mitogenome_core-paper’ outfile=‘Homo-sapiens_extract-TM-BC-Bison.fas’ data=Taxonomy ids= 9606 allBelow=true;
IOExceptionWithLineNumber: Line 1: ‘samples’ expected, got: ‘what’
Command usage: extract [name=] samples=<name1 name2 …>; - Extract samples to a new document
IOException: Line 1: ‘samples’ expected, got: ‘what’
Error: Execute failed: Line 1: ‘samples’ expected, got: ‘what’
Executing: show window=ExtractReads;

To confirm, I just tried extracting reads from a whole bunch of different rma6 files (those with multiple inputs and those with single file inputs) and none of them work. I get the same error:

Execute failed: Line 1: ‘samples’ expected, got: ‘what’

I think the read extracting function itself has a bug.

Thank you for the bug report. I have found the problem and have uploaded a new release - please try V6_20_18

Thanks Daniel! Works great now.