Convert DAA file to RMA file

Dear Dr.Daniel and everyone,

I use DIAMOND and MEGAN for the first time to analyze my sample from soil in HPCC server. I’ve got DAA file and I want to convert it into the RMA file.
I’ve download database from MEGAN download page


and then I convert the file following the generic pipeline for DIAMOND and MEGAN6, but it doesn’t work.
I also read this thread

from that thread I get that I didn’t need to use parameters parameters such as --acc2taxa, --acc2eggnog and --acc2interpro2go but I can use --mapDB parameter.

But, when I run the command line with --map parameter it’s doesn’t work.
And then, I tried to run with this command line daa2rma -i alignment/HA_result.daa -o megan/HA_result.rma and it’s work.

I got the result like this:

Version   MEGAN Community Edition (version 6.12.3, built 14 Aug 2018)
Copyright (C) 2018 Daniel H. Huson. This program comes with ABSOLUTELY NO WARRANTY.
Loading 1,787,384
Loading ncbi.tre: 1,787,388
In DAA file:  alignment/HA_result.daa
Output file:  megan/HA_result.rma
Classifications: Taxonomy
Parsing file: alignment/HA_result.daa
10% 20% 30% 40% 50% 60% 70% 80% 90% 100% (1312.4s)
Total reads:         1,032,425
Alignments:          6,618,743
100% (0.0s)
Binning reads: Initializing...
Initializing binning...
Using 'Naive LCA' algorithm for binning: Taxonomy
Binning reads...
Binning reads: Analyzing alignments
Total reads:        1,032,425
With hits:           1,032,425
Alignments:          6,618,743
Assig. Taxonomy:             0
MinSupport set to: 516
Binning reads: Applying min-support & disabled filter to Taxonomy...
Min-supp. changes:           0
Binning reads: Writing classification tables
Numb. Tax. classes:          1
Binning reads: Syncing
Class. Taxonomy:             1
100% (1034.5s)
Total time:  2357s
Peak memory: 2.0 of 2.1G

I don’t know the result is true or false for the analysis because I also read threads from MEGAN and the output is not like my output that I get.

Pleas guide me and give me an advice.

Thank you for your help.


Dear Lulu,

please use daa-meganizer and not daa2rma.
daa-meganizer prepares a daa file for opening in MEGAN.
The program is much faster than daa2rma and has the advantage that a second file is not created.

Then make sure that you have the very latest release of MEGAN, as the --mapDB option is new.

Run the program with option -h (or no options) to get a full printout of available options. You should see this:

Classification support:
-mdb, --mapDB [string] MEGAN mapping db (file megan-map.db).

MEGAN uses the mapping file to assign aligned reference sequences to taxonomic and functional classes. Without it, none of your reads will be assigned.

Dear Daniel,

Thank you for your reply.
Actually I have meganize the .daa file using MEGAN GUI because I can not convert .daa to .rma using CLI. Am I can have the same result between meganize the .daa file using GUI and CLI? I used database from MEGAN download file.

You appear to be using a very old version of MEGAN (2018), please update to the most recent version, and then the command line tools will work.

Dear Daniel,

Thank you so much for your reply. How I can update MEGAN to the latest version? Sould I uninstall it and then download MEGAN from MEGAN download file again?

Thank you

Please use the Window -> Check For Updates menu item