Command line usage v/6.5.7 import blast file?


I am a new user of MEGAN and am attempting to run it on a community cluster through the command line. I have multiple blastn output files in xml format (although they have .fasta endings) that I am trying to import into MEGAN.
So far, if I run MEGAN with the -h option, I am given the following options:
-f, MEGAN RMA file(s) to open.
-p, Properties file. Default value: /home/frickera/.Megan.def.
+w, Hide message window. Default value: false.
-S, Silent mode. Default value: false.
-d, Debug mode. Default value: false.
-v, Echo commandline options and be verbose. Default value: false.
-h, Show program usage and quit.

If I try to run:
$xvfb-run --auto-servernum --server-num=1 MEGAN -x “import blastFile=./xxx.fasta”
…or I have this command in a .txt file:…
$xvfb-run --auto-servernum --server-num=1 MEGAN -c commands.txt

I get the following error: “jloda.util.UsageException: Invalid, unknown or duplicate option: -x “import blastFile=./xxx.fasta”” or “jloda.util.UsageException: Invalid, unknown or duplicate option: -c commands.txt”, respectively.
I have tried piping the commands file to MEGAN (MEGAN < commands.txt), but then my shell hangs.

The question(s) I have is (are):

  1. How do I import a blast xml file into MEGAN without -x or -c options?
  2. Am I doing something wrong? (Do I need more commands in my command file? Am I missing a semicolon somewhere?)
  3. Are there any tutorials available for command-line usage?

Any help would be appreciated! Thanks in advance!

The easiest way to parse blast files so as to create MEGAN files is to use the command-line program MEGAN/tools/blast2rma. Run the program with no parameters to get a help message.

(It looks like you are running the Community Edition of MEGAN, which does not support the -x and -c options.)