Command line on a remote server

I’m trying to run something on a linux server, but I just can’t work out how. I’ve got a file with commands to pipe which works fine on my mac locally (and pops up a bunch of windows) but I can’t work out the xvfb-run commands. Firstly it looked like it was launching, but would just hang, so I thought this might be the solution - MEGAN UE Offline command line mode and I reinstalled telling it never to check for updates.

Now if I try something, e.g. xvfb-run --auto-servernum --server-num=1 MEGAN +g -x open file=‘test.rma6’ (test.rma6 was made using blast2rma and opens up fine locally) it just does nothing (takes me back to the command line after a second or two), no errors, same if I don’t specify anything with -x and I put commands in a file and use -c. xvfb-run --auto-servernum --server-num=1 MEGAN +g -h doesn’t do anything either.

I’m obviously missing something critically different between running on linux and mac, but I can’t work out what. Any pointers?

Argh, exhaust all options before posting…I found the megan error log:
MEGAN fatal error:
java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel
Apparently javafx doesn’t come with the openjdk on ubuntu!

I still can’t actually get it to work though - error.log now says:
“Version MEGAN Ultimate Edition (version 6.10.13, built 13 Mar 2018)
Copyright © 2018 Daniel H. Huson. This program comes with ABSOLUTELY NO WARRANTY.
3D PCoA viewer not supported on this platform”
And doesn’t do anything.

I just took a look at this. There is a bug that causes MEGAN to write the help output to the error.log file (not very helpful…)

This will be fixed in the next release

I managed to get it sorted after another look through the error log again - I didn’t realise that I needed to give it the license key as a string, I had put it in a file and was giving the path to the file - it didn’t want the key to print the helpfile to the log with -h but did to actually run anything, so without checking the error.log again (which I didn’t straight away, because I knew my command file worked!) I hadn’t realised it was saying the licence key was wrong.

One way to specify the license key directly is to put it into MEGAN’s preferences file ~/.Megan.def like this