Can't connect to public megan server

I’m a new user trying to get onto the meganserver to practice using the desktop app and paly around wit the files available on it. When I first opened it I tried to connect to the server already listed: url=‘’ and got the following message: IOException: 503 Service Temporarily Unavailable
Error: Execute failed: 503 Service Temporarily Unavailable

Then I thought maybe the issue was the server was wrong so I looked through the manual and found this server listed: url=‘’ but when I tried to connect I got this error: Error: Execute failed: Could not extract response: no suitable HttpMessageConverter found for response type [class [Lrusch.megan5client…

Is this a common issue? Which server is correct? Is the problem with my computer or the server I’m trying to connect to, or just the url?

Alternatively, if you know any tutorials or other servers to connect to that could help me get practicing, please let me know! Thanks

We’ve had trouble with the air-con in our server room and so some services are down. We also had a webpage serving data from our recent paper on long read analysis

but that webpage also seems to be down at present.