BLASTn files won't import into MEGAN 6.6.7

I have been using MEGAN v6 for a few months now without problem. I always import my blastn file and select BlastXML under format and BlastN under mode. I then import my fasta file with the reads. I updated to version 6.6.7 and importing doesn’t work anymore. It says it’s not an XML file. But if I run the same files on version 6.5.7 it works beautifully. Help? Is this a bug?

can you please let me known what the file name is and please send me the first 100 lines of the file.
Some code used for recognizing file types has recently been changed, perhaps something broke

The files’ names I was trying to use are:



I’m attaching abbreviated files with the first ~100 lines of each.

Thanks for your quick reply!!51-62C_blast100.blastn (4.5 KB)
51-62_nonch100.fa (5.6 KB)

This is a BlastText file, not a BlastXML file… Set format to BlastText and then there is no problem

I tried this (and many other options) several times yesterday and it did not work. Today it worked as BlastText, as you suggest. Don’t know what the difference was. What is the difference between BlastText vs. BlastXML? Thanks a lot!

They are two different formats.